Logo Asguard starmade Retour au site

Asguard Community

About memory usage

Hello!
There was a situation with a shortage of RAM. Tell me, maybe I’m wrong tuned? Screenshots are attached.
2017-11-24_112759
2017-11-24_112706

Hello, for me everything seem to be alright, I have the same settings.

But sometime for no reason you have to logg off to free some memory, it’s the little joy of playing starmade I tink.

I can not understand why the game does not see all the memory allocated to it.
This is very sad, because the problems begin at the most crucial moment, for example, at the moment of the battle.

Yop,

Some details are different for me :

Don’t know if it’s better or not… :thinking:

OOOh dumb question but : is it your client memory settings or your server memory settings ??

Hi! It’s a client memory settings. And I have a counter question - can we change server memory settings? I tried experimenting - I set various parameters for Java, by the way, in the Java settings, I also set the parameters -Xms1024m -Xmx8192m (this habit was left by Minecraft). I also tried changing the memory settings in the client, but the result is always the same. Perhaps there are « hidden » settings, you know how it is, you need to open a certain file and change the parameter in it and resave?
2017-11-25_102647

In the first post on the bottom screenshot shows statistics from the local game, in this screenshot statistics from online. They are generally the same.
2017-11-25_110218

Another question. A little off topic, but …
We have a core marker near the base, but there is nothing in this place (in the screenshot in the lower left corner). Obviously this is a bug. How can it be removed?

For the unreal entity, we can delete it, just send me in MP your coord and I will delete it in the day.
To continue with your memory issue, do you use the java version of the game or the version on windows ?

Good luck ^^

1 Like

I used the java version of the game, as I understood from the screenshot. Now I’ve changed my settings.
The parameters have changed, but not much.
Before
2017-11-25_191842
After
parameter string
-Xms1024m -Xmx8192m -XX:+DoEscapeAnalysis -XX:+AggressiveOpts -XX:+EliminateLocks
2017-11-25_192431
Memory usage in local game
2017-11-25_193450

And is it better ?

I do not see a difference and it’s surprising because now the settings for Java from Windows, and there is allocated a lot of memory …

Extremely strange… so the pb is not here. Have you try a fresh install of Starmade ? Honestly, I have no idea what is wrong… Sorry :confused:

Hey,

How much RAM have you ?

Have you already look how much is used when starmade run, and when starmand don’t run in system ?

Because if you have 4GB, then 1gb for system, let 2gb for starmade, he let you 1gb that goes to be “preserved” by system sometime.

In the first post I published the client settings. I have Windows 7 х64, 16 GB RAM.

hum weird, but it reminds me an issue we (some players) encounterded this summer, the SMD client couldnt use all the allowed ram, and the player had to stop using the java version of the game but the one on their computer instead (idk if i’m clear saying this like that).

I tried to run a non-Java version of the game. That’s what happened in the end. I confess, I’m at a loss. Could there be a reason for using the free version of the game?

local game
2017-11-26_192506_local
online
2017-11-26_193029_online
client settings
2017-11-26_193151

I continue to play on the Java version of the game. I suspect that allocation of memory occurs dynamically if necessary.

What you see is just, what the java virtual machine actually allocated. so the value you set in the config is more like an upper bound for memory allocation. It makes no sense to allocate all 8G of memory, if they are not needed, so this behavior makes sense. It the value shown should increase with actual memory requirements.

Yes, that’s exactly what I thought.